Query response size limit


I’m receiving the following message in GraphStudio:

“The query response size is 49MB, which exceeds limit 32MB.”

If I’m not mistaken, this is supposed to be controlled by the nginx.client_max_body_size parameter, as described here

If that’s so, then it looks like there’s a problem:

  • When running gadmin --dump-config, it looks like this parameter is set to 128 (which matches the documentation)
  • Altering the value of this parameter, didn’t resolve the issue.

So, either the query response size is controlled by another parameter, or there’s a problem with the mechanism… :slightly_frowning_face:


nginx.client_max_body_size is for the input payload size.

For the output size, you can extend the default limit for an individual query:

Not sure if there is a config parameter to set this persistently.

Ohhhh… Gotcha!
Thanks a lot Victor! :smiley:
I’ll try to investigate - maybe there is a config parameter for this (I’d like this to be consistent both for REST and for GraphStudio queries)